Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?Watu QuizWatu Pro

Plugin · watu

Watu Quiz

15 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Watu Quiz safe? The full page →

  • Dec 24, 2025Watu Quiz: Missing AuthorizationCVE-2025-68587 · affects up to 3.4.5 · reported by PatchstackMedium 4.3

    Missing Authorization vulnerability in Bob Watu Quiz watu allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Watu Quiz: from n/a through <= 3.4.5.

  • Dec 16, 2025Watu Quiz: Missing AuthorizationCVE-2025-67976 · affects up to 3.4.5 · reported by PatchstackMedium 6.5

    Missing Authorization vulnerability in Bob Watu Quiz watu allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Watu Quiz: from n/a through <= 3.4.5.

  • Oct 25, 2025Watu Quiz: Stored Cross-Site ScriptingCVE-2025-11238 · reported by WordfenceHigh 7.2

    The Watu Quiz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the HTTP Referer header in versions less than, or equal to, 3.4.4 due to insufficient input sanitization and output escaping when the "Save source URL" option is enabled. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an user accesses an injected page.

  • Apr 22, 2025Watu Quiz: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-46242 · affects up to 3.4.3 · reported by PatchstackHigh 7.6

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Bob Watu Quiz watu allows SQL Injection.This issue affects Watu Quiz: from n/a through <= 3.4.3.

  • Apr 1, 2025Watu Quiz: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-30844 · affects up to 3.4.2 · reported by PatchstackHigh 7.1

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bob Watu Quiz watu allows Reflected XSS.This issue affects Watu Quiz: from n/a through <= 3.4.2.

  • Dec 2, 2024Watu Quiz: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2024-53792 · affects up to 3.4.1.2 · reported by PatchstackHigh 8.5

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Bob Watu Quiz watu allows SQL Injection.This issue affects Watu Quiz: from n/a through <= 3.4.1.2.

  • Jul 12, 2024Watu Quiz: Does not sanitise and escape some of its settingsCVE-2024-2640 · fixed in 3.4.1.2 · reported by WPScanMedium 5.4

    The Watu Quiz WordPress plugin before 3.4.1.2 does not sanitise and escape some of its settings, which could allow users such as authors (if they've been authorized by admins) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • Apr 9, 2024Watu Quiz: Stored Cross-Site ScriptingCVE-2024-0873 · affects up to 3.4.1 · reported by WordfenceMedium 6.4

    The Watu Quiz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'watu-basic-chart' shortcode in all versions up to, and including, 3.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Apr 9, 2024Watu Quiz: Sensitive Information ExposureCVE-2024-0872 · affects up to 3.4.1 · reported by WordfenceMedium 4.3

    The Watu Quiz plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.4.1 via the watu-userinfo shortcode. This makes it possible for authenticated attackers, with contributor-level access and above, to extract sensitive user meta data which can include session tokens and user emails.

  • Aug 14, 2023Unauth.CVE-2023-30483 · affects up to 3.3.9.2 · reported by PatchstackHigh 7.1

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Kiboko Labs Watu Quiz plugin <= 3.3.9.2 versions.

  • Jun 4, 2023A vulnerability was found in Watu Quiz Plugin up to 2.6.7 on WordPress.CVE-2015-10111 · affects up to 2.6.7 · reported by VulDBMedium 6.3

    A vulnerability was found in Watu Quiz Plugin up to 2.6.7 on WordPress. It has been rated as critical. This issue affects the function watu_exams of the file controllers/exam.php of the component Exam Handler. The manipulation of the argument quiz leads to sql injection. The attack may be initiated remotely. Upgrading to version 2.6.8 is able to address this issue. The patch is named bf42e7cfd819a3e76cf3e1465697e89f4830590c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230651.

  • Apr 7, 2023Auth.CVE-2023-25022 · affects up to 3.3.8 · reported by PatchstackMedium 5.9

    Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Kiboko Labs Watu Quiz plugin <= 3.3.8 versions.

  • Mar 3, 2023Watu Quiz: Reflected Cross-Site ScriptingCVE-2023-0968 · affects up to 3.3.9 · reported by WordfenceMedium 6.1

    The Watu Quiz plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘dn’, 'email', 'points', and 'date' parameters in versions up to, and including, 3.3.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

  • Feb 21, 2023Watu Quiz: Does not sanitise and escape some of its settingsCVE-2023-0429 · fixed in 3.3.8.2 · reported by WPScanMedium 4.8

    The Watu Quiz WordPress plugin before 3.3.8.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

  • Feb 21, 2023Watu Quiz: Does not sanitise and escape a parameter before outputting it back in the pageCVE-2023-0428 · fixed in 3.3.8.2 · reported by WPScanMedium 6.1

    The Watu Quiz WordPress plugin before 3.3.8.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.