Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · tweet-old-post
Revive Old Posts
2 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 26, 2025Revive Old Posts: Missing AuthorizationCVE-2025-62954 · affects up to 9.3.3 · reported by PatchstackMedium 4.3
Missing Authorization vulnerability in rsocial Revive Old Posts tweet-old-post allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Revive Old Posts: from n/a through <= 9.3.3.
Jan 30, 2023Revive Old Posts: Unserializes user input provided via the settingsCVE-2022-4680 · fixed in 9.0.11 · reported by WPScanHigh 7.2
The Revive Old Posts WordPress plugin before 9.0.11 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.