Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,080 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?SqueezeLanding Page Cat – Coming Soon Page, Maintenance Page & Squeeze PagesWP Lead Plus XLanding Page Builder – Lead Page – Optin Page – Squeeze Page – WordPress Landing Pages

Plugin · squeeze

Squeeze

6 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Squeeze safe? The full page →

  • Oct 16, 2026Squeeze: Does not perform a capability check on one of its AJAX actionsCVE-2026-110029 · fixed in 1.8.1 · reported by WPScanMedium 5.4

    The Squeeze WordPress plugin before 1.8.1 does not perform a capability check on one of its AJAX actions, allowing authenticated users with a role as low as Subscriber to revert any attachment to its backup copy and to permanently delete that backup and the plugin's generated WebP derivatives, regardless of ownership.

  • Aug 10, 2026Squeeze: Does not validate the file type or extension of the per-size image data written by one of its attachment-update actionsCVE-2026-16985 · fixed in 1.7.12 · reported by WPScanHigh 8.8

    The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the upload_files capability (Author and above) to write an executable PHP file into the uploads directory and achieve remote code execution.

  • Mar 13, 2026Squeeze: Path Traversal: '.../...//'CVE-2026-32415 · affects up to 1.7.7 · reported by PatchstackMedium 5

    Path Traversal: '.../...//' vulnerability in Bogdan Bendziukov Squeeze squeeze allows Path Traversal.This issue affects Squeeze: from n/a through <= 1.7.7.

  • Apr 9, 2025Squeeze: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2025-31003 · affects up to 1.6 · reported by PatchstackLow 2.7

    Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Bogdan Bendziukov Squeeze squeeze allows Retrieve Embedded Sensitive Data.This issue affects Squeeze: from n/a through <= 1.6.

  • Apr 9, 2025Squeeze: Unrestricted Upload of File with Dangerous TypeCVE-2025-31002 · affects up to 1.6 · reported by PatchstackCritical 9.1

    Unrestricted Upload of File with Dangerous Type vulnerability in Bogdan Bendziukov Squeeze squeeze allows Using Malicious Files.This issue affects Squeeze: from n/a through <= 1.6.

  • Jun 21, 2024Squeeze: Unrestricted Upload of File with Dangerous TypeCVE-2024-35767 · affects up to 1.4 · reported by PatchstackCritical 9.1

    Unrestricted Upload of File with Dangerous Type vulnerability in Bogdan Bendziukov Squeeze allows Code Injection.This issue affects Squeeze: from n/a through 1.4.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.