Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?Search & ReplaceCM On Demand Search And ReplaceLinksy Search and ReplaceBravo Search & Replace

Plugin · cm-on-demand-search-and-replace

CM On Demand Search And Replace

5 known vulnerabilities on record. Add your version above to see which ones affect you.

Is CM On Demand Search And Replace safe? The full page →

  • Dec 16, 2025CM On Demand Search And Replace: Missing AuthorizationCVE-2025-54045 · affects up to 1.5.5 · reported by PatchstackMedium 4.3

    Missing Authorization vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.5.

  • Aug 14, 2025CM On Demand Search And Replace: Cross-Site Request Forgery (CSRF)CVE-2025-54728 · affects up to 1.5.2 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Cross Site Request Forgery.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.2.

  • Aug 14, 2025CM On Demand Search And Replace: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-54727 · affects up to 1.5.2 · reported by PatchstackMedium 5.9

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Stored XSS.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.2.

  • Nov 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace plugin <= 1.3.0 versions.CVE-2023-28749 · affects up to 1.3.0 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace plugin <= 1.3.0 versions.

  • Aug 18, 2023Auth.CVE-2023-31228 · fixed in 1.3.1 · reported by PatchstackMedium 5.9

    Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace plugin <= 1.3.0 versions.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.