Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?Search & ReplaceCM On Demand Search And ReplaceLinksy Search and ReplaceBravo Search & Replace
Plugin · search-and-replace
Search & Replace
2 known vulnerabilities on record. Add your version above to see which ones affect you.
Jul 22, 2024Search & Replace: Deserialization of Untrusted DataCVE-2024-38759 · affects up to 3.2.2 · reported by PatchstackMedium 5.4
Deserialization of Untrusted Data vulnerability in WP MEDIA SAS Search & Replace search-and-replace.This issue affects Search & Replace: from n/a through 3.2.2.
Jun 13, 2024Search & Replace: Does not sanitize and escape a parameter before using it in a SQL statementCVE-2024-4145 · fixed in 3.2.2 · reported by WPScanHigh 7.2
The Search & Replace WordPress plugin before 3.2.2 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks (such as within a multi-site network).
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.