Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?WooCommerce Recover Abandoned CartMapSVG3D FlipBookWP AbstractsWPCargo Track & Tracetracking-code-managerInteractive Geo MapsInteractive Contact Form and Multi Step Form Builder

Plugin · interactive-geo-maps

Interactive Geo Maps

5 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Interactive Geo Maps safe? The full page →

  • Sep 2, 2026Unauthenticated Cross Site Scripting (XSS) in Interactive Geo Maps <= 1.6.30 versions.CVE-2026-81770 · affects up to 1.6.30 · reported by PatchstackHigh 7.1

    Unauthenticated Cross Site Scripting (XSS) in Interactive Geo Maps <= 1.6.30 versions.

  • May 14, 2026MapGeo – Interactive Geo Maps: Reflected Cross-Site ScriptingCVE-2025-15345 · affects up to 1.6.27 · reported by WordfenceMedium 6.1

    The MapGeo – Interactive Geo Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'map' parameter in the display-map shortcode in all versions up to, and including, 1.6.27 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

  • Apr 11, 2025Interactive Geo Maps: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-32525 · affects up to 1.6.24 · reported by PatchstackHigh 7.1

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MapGeo Interactive Geo Maps interactive-geo-maps allows Reflected XSS.This issue affects Interactive Geo Maps: from n/a through <= 1.6.24.

  • Apr 25, 2023Auth.CVE-2023-23866 · fixed in 1.5.9 · reported by PatchstackMedium 6.5

    Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Carlos Moreira Interactive Geo Maps plugin <= 1.5.8 versions.

  • Feb 7, 2023Interactive Geo Maps: Stored Cross-Site ScriptingCVE-2023-0731 · affects up to 1.5.9 · reported by WordfenceMedium 6.4

    The Interactive Geo Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the action content parameter in versions up to, and including, 1.5.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with editor level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.