Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?Popup BuilderPopupKitBraveWP Popup BuilderPretty Simple Popup BuilderPop ups, Exit intent popups, email popups, banners, bars, countdowns and cart savers – PromolayerConvertForce Popup BuilderInstant Popup Builder
Plugin · popup-builder-block
PopupKit
7 known vulnerabilities on record. Add your version above to see which ones affect you.
Feb 10, 2026PopupKit: Authorization bypassCVE-2025-14895 · affects up to 2.2.0 · reported by WordfenceMedium 5.4
The PopupKit plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.2.0. This is due to the plugin not properly verifying that a user is authorized to access the /popup/logs REST API endpoint. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read and delete analytics data including device types, browser information, countries, referrer URLs, and campaign metrics.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Feb 4, 2026Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers: Generic SQL InjectionCVE-2025-13192 · affects up to 2.2.0 · reported by WordfenceHigh 8.2
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to generic SQL Injection via the multiple REST API endpoints in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Vulnerability was patched in version 2.2.1 for unauthenticated users, and fully patched in version 2.2.3 for Administrator+ level users.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jan 6, 2026Popupkit: Arbitrary subscriber data deletionCVE-2025-14441 · affects up to 2.2.0 · reported by WordfenceMedium 4.3
The Popupkit plugin for WordPress is vulnerable to arbitrary subscriber data deletion due to missing authorization on the DELETE `/subscribers` REST API endpoint in all versions up to, and including, 2.2.0. This is due to the `permission_callback` only validating wp_rest nonce without checking user capabilities. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary subscriber records.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Dec 30, 2025PopupKit: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2025-69026 · affects up to 2.1.5 · reported by PatchstackMedium 4.3
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Roxnor PopupKit popup-builder-block allows Retrieve Embedded Sensitive Data.This issue affects PopupKit: from n/a through <= 2.1.5.
Dec 18, 2025PopupKit: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-14314 · affects up to 2.1.5 · reported by PatchstackHigh 8.5
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Roxnor PopupKit popup-builder-block allows Blind SQL Injection.This issue affects PopupKit: from n/a through <= 2.1.5.
Oct 24, 2025Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers: Server-Side Request ForgeryCVE-2025-10861 · affects up to 2.1.4 · reported by WordfenceHigh 7.5
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Oct 9, 2025Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers: SQL InjectionCVE-2025-10862 · affects up to 2.1.3 · reported by WordfenceHigh 7.5
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 2.1.3. This is due to insufficient escaping on the 'id' parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.