Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?PolylangHyyan WooCommerce Polylang IntegrationSupertext Translation and ProofreadingAdd Polylang support for CustomizerAI Translation for Polylangtheme-translation-for-polylang
Plugin · polylang
Polylang
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 14, 2026Polylang: Deserialization of Untrusted DataCVE-2026-97278 · affects up to 3.8.9 · reported by PatchstackHigh 7.2
Deserialization of Untrusted Data vulnerability in WP SYNTEX Polylang polylang allows Object Injection.This issue affects Polylang: from n/a through 3.8.9.
Oct 5, 2026Polylang: Missing AuthorizationCVE-2026-39783 · affects up to 3.8.7 · reported by PatchstackMedium 4.3
Missing Authorization vulnerability in WP SYNTEX Polylang polylang allows Retrieve Embedded Sensitive Data.This issue affects Polylang: from n/a through 3.8.7.
Sep 30, 2026Contributor Cross Site Scripting (XSS) in Polylang <= 3.8.9 versions.CVE-2026-97279 · affects up to 3.8.9 · reported by PatchstackMedium 6.5
Contributor Cross Site Scripting (XSS) in Polylang <= 3.8.9 versions.
Jul 23, 2026Chouby Polylang and Chouby Polylang Pro: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2026-65458 · affects up to 3.8.5 · reported by PatchstackMedium 4.3
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Chouby Polylang and Chouby Polylang Pro allows Retrieve Embedded Sensitive Data. This issue affects Polylang: through 3.8.5; Polylang Pro: through 3.8.5.
Oct 31, 2025Polylang: Deserialization of Untrusted DataCVE-2025-64353 · affects up to 3.7.3 · reported by PatchstackHigh 8.8
Deserialization of Untrusted Data vulnerability in Chouby Polylang polylang allows Object Injection.This issue affects Polylang: from n/a through <= 3.7.3.
Jul 10, 2014Cross-site scripting (XSS) vulnerability in the Polylang plugin before 1.5.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via veCVE-2014-4855 · fixed in 1.5.2 · reported by MITREMedium 4.3
Cross-site scripting (XSS) vulnerability in the Polylang plugin before 1.5.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via vectors related to a user description. NOTE: some of these details are obtained from third party information.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.