Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · new-user-approve

New User Approve

10 known vulnerabilities on record. Add your version above to see which ones affect you.

Is New User Approve safe? The full page →

  • Sep 30, 2026New User Approve: Does not properly verify authentication on a set of integration REST API routesCVE-2026-83560 · fixed in 3.2.10 · reported by WPScanMedium 5.3

    The New User Approve WordPress plugin before 3.2.10 does not properly verify authentication on a set of integration REST API routes when the integration is unconfigured, allowing unauthenticated attackers to retrieve personal data (id, username, email address and registration date) of registered users.

  • Aug 20, 2026New User Approve: Missing AuthorizationCVE-2026-28163 · affects up to 3.2.8 · reported by PatchstackMedium 5.3

    Missing Authorization vulnerability in myCred New User Approve allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects New User Approve: from n/a through 3.2.8.

  • Mar 25, 2026New User Approve: Missing AuthorizationCVE-2026-25390 · affects up to 3.2.3 · reported by PatchstackMedium 6.5

    Missing Authorization vulnerability in Saad Iqbal New User Approve new-user-approve allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects New User Approve: from n/a through <= 3.2.3.

  • Feb 20, 2026New User Approve: Missing AuthorizationCVE-2025-69063 · affects up to 3.2.0 · reported by PatchstackHigh 8.6

    Missing Authorization vulnerability in Saad Iqbal New User Approve new-user-approve allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects New User Approve: from n/a through <= 3.2.0.

  • Jan 28, 2026New User Approve: Unauthorized access of data and modification of dataCVE-2026-0832 · affects up to 3.2.2 · reported by WordfenceHigh 7.3

    The New User Approve plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a missing capability check on multiple REST API endpoints in all versions up to, and including, 3.2.2. This makes it possible for unauthenticated attackers to approve or deny user accounts, retrieve sensitive user information including emails and roles, and force logout of privileged users.

  • Dec 9, 2025New User Approve: Cross-Site Request Forgery (CSRF)CVE-2025-63030 · affects up to 3.2.3 · reported by PatchstackHigh 7.1

    Cross-Site Request Forgery (CSRF) vulnerability in Saad Iqbal New User Approve new-user-approve allows Cross Site Request Forgery.This issue affects New User Approve: from n/a through <= 3.2.3.

  • Nov 18, 2025New User Approve: Unauthorized data disclosureCVE-2025-12770 · affects up to 3.0.9 · reported by WordfenceMedium 5.3

    The New User Approve plugin for WordPress is vulnerable to unauthorized data disclosure in all versions up to, and including, 3.0.9 due to insufficient API key validation using loose equality comparison. This makes it possible for unauthenticated attackers to retrieve personally identifiable information (PII), including usernames and email addresses of users with various approval statuses via the Zapier REST API endpoints, by exploiting PHP type juggling with the api_key parameter set to "0" on sites where the Zapier API key has not been configured.

  • Dec 13, 2024New User Approve: Missing AuthorizationCVE-2024-54323 · affects up to 2.6.2 · reported by PatchstackMedium 5.4

    Missing Authorization vulnerability in Saad Iqbal New User Approve new-user-approve allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects New User Approve: from n/a through <= 2.6.2.

  • Dec 29, 2023New User Approve: Cross-Site Request Forgery (CSRF)CVE-2023-50902 · affects up to 2.5.1 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in WPExpertsio New User Approve.This issue affects New User Approve: from n/a through 2.5.1.

  • Jun 27, 2022New User Approve: Does not have CSRF check in placeCVE-2022-1625 · fixed in 2.4 · reported by WPScanMedium 4.3

    The New User Approve WordPress plugin before 2.4 does not have CSRF check in place when updating its settings and adding invitation codes, which could allow attackers to add invitation codes (for bypassing the provided restrictions) and to change plugin settings by tricking admin users into visiting specially crafted websites.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.