Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · music-store
Music Store
5 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 23, 2026Music Store – WordPress eCommerce: Directory TraversalCVE-2026-115497 · affects up to 1.4.7 · reported by WordfenceHigh 7.5
The Music Store – WordPress eCommerce plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.4.7 via the 'f' parameter parameter. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. Exploitation requires a valid purchase_id token, which any user can obtain by making a single low-cost purchase or receiving a shared download link.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Sep 5, 2026Music Store: Does not sanitise and escape user input before using it in a SQL statementCVE-2026-82304 · fixed in 1.4.5 · reported by WPScanHigh 8.6
The Music Store WordPress plugin before 1.4.5 does not sanitise and escape user input before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users.
Jan 27, 2025Music Store: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24626 · affects up to 1.1.19 · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Music Store music-store allows Reflected XSS.This issue affects Music Store: from n/a through <= 1.1.19.
Jun 7, 2024Music Store - WordPress eCommerce versions prior to 1.1.14: SQL injectionCVE-2024-36082 · fixed in 1.1.14 · reported by vultures@jpcert.or.jpMedium 6.5
SQL injection vulnerability in Music Store - WordPress eCommerce versions prior to 1.1.14 allows a remote authenticated attacker with an administrative privilege to execute arbitrary SQL commands. Information stored in the database may be obtained or altered by the attacker.
Sep 17, 2019The music-store plugin before 1.0.43 for WordPress has XSS via the wp-admin/admin.php?page=music-store-menu-reports from_year parameter.CVE-2016-10992 · fixed in 1.0.43 · reported by MITREMedium 6.1
The music-store plugin before 1.0.43 for WordPress has XSS via the wp-admin/admin.php?page=music-store-menu-reports from_year parameter.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.