Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · layouts-for-elementor
Layouts for Elementor
2 known vulnerabilities on record. Add your version above to see which ones affect you.
Jun 6, 2025Layouts for Elementor: Cross-Site Request Forgery (CSRF)CVE-2025-30948 · affects up to 1.11 · reported by PatchstackMedium 4.3
Cross-Site Request Forgery (CSRF) vulnerability in Giraphix Creative Layouts for Elementor layouts-for-elementor allows Cross Site Request Forgery.This issue affects Layouts for Elementor: from n/a through <= 1.11.
Mar 31, 2024Layouts for Elementor: Unrestricted Upload of File with Dangerous TypeCVE-2024-30533 · fixed in 1.8 · reported by PatchstackHigh 7.5
Unrestricted Upload of File with Dangerous Type vulnerability in Techeshta Layouts for Elementor.This issue affects Layouts for Elementor: from n/a before 1.8.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.