Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?kanbanWP Project Manager – Task, team, and project management plugin featuring kanban board and gantt chartsTaskbuilder – Project Management & Task Management Tool With Kanban BoardLazyTasks – Project & Task Management with Collaboration, Kanban and Gantt Chart
Plugin · kanban
kanban
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Nov 1, 2024Kanban Boards for: Missing AuthorizationCVE-2024-37226 · affects up to 2.5.21 · reported by PatchstackMedium 5.3
Missing Authorization vulnerability in Kanban for WordPress Kanban Boards for WordPress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Kanban Boards for WordPress: from n/a through 2.5.21.
Mar 31, 2024Kanban Boards for: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-31103 · affects up to 2.5.21 · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kanban for WordPress Kanban Boards for WordPress allows Reflected XSS.This issue affects Kanban Boards for WordPress: from n/a through 2.5.21.
Dec 29, 2023Kanban Boards for: Improper Control of Generation of Code ('Code Injection')CVE-2023-40606 · affects up to 2.5.21 · reported by PatchstackCritical 9.1
Improper Control of Generation of Code ('Code Injection') vulnerability in Kanban for WordPress Kanban Boards for WordPress.This issue affects Kanban Boards for WordPress: from n/a through 2.5.21.
Jun 27, 2023Kanban Boards for: Does not sanitise and escape some of its settingsCVE-2023-0873 · fixed in 2.5.21 · reported by WPScanMedium 4.8
The Kanban Boards for WordPress plugin before 2.5.21 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Jun 22, 2023Auth.CVE-2023-34368 · affects up to 2.5.20 · reported by PatchstackMedium 5.9
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Kanban for WordPress Kanban Boards for WordPress plugin <= 2.5.20 versions.
May 9, 2023Auth.CVE-2023-23884 · affects up to 2.5.20 · reported by PatchstackMedium 5.9
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Kanban for WordPress Kanban Boards for WordPress plugin <= 2.5.20 versions.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.