Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?K Elementspowerpack-elements

Plugin · powerpack-elements

powerpack-elements

6 known vulnerabilities on record. Add your version above to see which ones affect you.

Is powerpack-elements safe? The full page →

  • Jun 17, 2026Unauthenticated Broken Authentication in PowerPack Pro for Elementor < v2.13.0 versions.CVE-2026-42629 · reported by PatchstackHigh 8.8

    Unauthenticated Broken Authentication in PowerPack Pro for Elementor < v2.13.0 versions.

  • Dec 23, 2025PowerPack Pro for Elementor: Missing AuthorizationCVE-2024-24844 · affects up to 2.10.6 · reported by PatchstackHigh 7.5

    Missing Authorization vulnerability in IdeaBox Creations PowerPack Pro for Elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PowerPack Pro for Elementor: from n/a through 2.10.6.

  • Aug 1, 2024PowerPack Pro for Elementor: Improper Privilege ManagementCVE-2024-39634 · affects up to 2.10.14 · reported by PatchstackHigh 8.8

    Improper Privilege Management vulnerability in IdeaBox PowerPack Pro for Elementor allows Privilege Escalation.This issue affects PowerPack Pro for Elementor: from n/a through 2.10.14.

  • Jun 8, 2024PowerPack Pro for Elementor: Privilege escalationCVE-2024-3668 · affects up to 2.10.17 · reported by WordfenceHigh 8.8

    The PowerPack Pro for Elementor plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 2.10.17. This is due to the plugin not restricting low privileged users from setting a default role for a registration form. This makes it possible for authenticated attackers, with contributor-level access and above, to create a registration form with administrator set as the default role and then register as an administrator.

  • Feb 21, 2024PowerPack Pro for Elementor: Cross-Site Request Forgery (CSRF)CVE-2024-24843 · fixed in 2.10.8 · reported by PatchstackHigh 7.1

    Cross-Site Request Forgery (CSRF) vulnerability in PowerPack Addons for Elementor PowerPack Pro for Elementor.This issue affects PowerPack Pro for Elementor: from n/a before 2.10.8.

  • Dec 14, 2023Vulnerability in IdeaBox Creations PowerPack Pro for Elementor.This issue affects PowerPack Pro for Elementor: from n/a through 2.9.23.CVE-2023-49739 · affects up to 2.9.23 · reported by PatchstackHigh 7.1

    Vulnerability in IdeaBox Creations PowerPack Pro for Elementor.This issue affects PowerPack Pro for Elementor: from n/a through 2.9.23.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.