Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?H5PSNORDIAN'sH5P CSS Editor
Plugin · h5p
H5P
7 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 22, 2026H5P: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-112867 · affects up to 1.17.9 · reported by PatchstackMedium 6.5
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in H5P H5P h5p allows Stored XSS.This issue affects H5P: from n/a through 1.17.9.
Oct 21, 2026H5P: Authorization Bypass Through User-Controlled KeyCVE-2026-112868 · affects up to 1.17.9 · reported by PatchstackMedium 4.3
Authorization Bypass Through User-Controlled Key vulnerability in H5P H5P h5p allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects H5P: from n/a through 1.17.9.
Jun 26, 2026Contributor Arbitrary File Deletion in H5P <= 1.17.7 versions.CVE-2026-57321 · reported by PatchstackHigh 7.1
Contributor Arbitrary File Deletion in H5P <= 1.17.7 versions.
Jun 25, 2026Unauthenticated Cross Site Scripting (XSS) in H5P <= 1.17.6 versions.CVE-2026-56006 · affects up to 1.17.6 · reported by PatchstackHigh 7.1
Unauthenticated Cross Site Scripting (XSS) in H5P <= 1.17.6 versions.
Dec 24, 2025H5P: Missing AuthorizationCVE-2025-68505 · affects up to 1.16.1 · reported by PatchstackMedium 5.3
Missing Authorization vulnerability in icc0rz H5P h5p allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects H5P: from n/a through <= 1.16.1.
Oct 26, 2025H5P: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-62951 · affects up to 1.16.0 · reported by PatchstackMedium 6.5
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in icc0rz H5P h5p allows Stored XSS.This issue affects H5P: from n/a through <= 1.16.0.
Jun 27, 2024Interactive Content: Does not validate uploadsCVE-2024-3111 · fixed in 1.15.8 · reported by WPScanMedium 5.4
The Interactive Content WordPress plugin before 1.15.8 does not validate uploads which could allow a Contributors and above to update malicious SVG files, leading to Stored Cross-Site Scripting issues
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.