Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · google-document-embedder
Google Doc Embedder
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Apr 29, 2024Google Doc Embedder: Server Side Request ForgeryCVE-2024-0216 · affects up to 2.6.4 · reported by WordfenceMedium 6.4
The Google Doc Embedder plugin for WordPress is vulnerable to Server Side Request Forgery via the 'gview' shortcode in versions up to, and including, 2.6.4. This can allow authenticated attackers with contributor-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Aug 14, 2019The google-document-embedder plugin before 2.6.2 for WordPress has CSRF.CVE-2016-10882 · fixed in 2.6.2 · reported by MITREHigh 8.8
The google-document-embedder plugin before 2.6.2 for WordPress has CSRF.
Aug 14, 2019The google-document-embedder plugin before 2.6.2 for WordPress has XSS.CVE-2016-10881 · fixed in 2.6.2 · reported by MITREMedium 6.1
The google-document-embedder plugin before 2.6.2 for WordPress has XSS.
Aug 14, 2019The google-document-embedder plugin before 2.6.1 for WordPress has XSS.CVE-2016-10880 · fixed in 2.6.1 · reported by MITREMedium 6.1
The google-document-embedder plugin before 2.6.1 for WordPress has XSS.
Feb 19, 2015Cross-site scripting (XSS) vulnerability in the Google Doc Embedder plugin before 2.5.19 for WordPress allows remote attackers to inject arbitrary web script orCVE-2015-1879 · fixed in 2.5.19 · reported by MITREMedium 4.3
Cross-site scripting (XSS) vulnerability in the Google Doc Embedder plugin before 2.5.19 for WordPress allows remote attackers to inject arbitrary web script or HTML via the profile parameter in an edit action in the gde-settings page to wp-admin/options-general.php.
Dec 2, 2014SQL injection vulnerability in view.php in the Google Doc Embedder plugin before 2.5.15 for WordPress allows remote attackers to execute arbitrary SQL commands CVE-2014-9173 · fixed in 2.5.15 · reported by MITREHigh 7.5
SQL injection vulnerability in view.php in the Google Doc Embedder plugin before 2.5.15 for WordPress allows remote attackers to execute arbitrary SQL commands via the gpid parameter.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.