Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · gigpress
GigPress
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Feb 12, 2024GigPress: Does not sanitise and escape some of its settingsCVE-2023-7233 · affects up to 2.3.29 · reported by WPScanMedium 4.8
The GigPress WordPress plugin through 2.3.29 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Feb 27, 2023GigPress: Does not validate and escape some of its shortcode attributes before using them in SQL statement/sCVE-2023-0381 · affects up to 2.3.28 · reported by WPScanHigh 8.8
The GigPress WordPress plugin through 2.3.28 does not validate and escape some of its shortcode attributes before using them in SQL statement/s, which could allow any authenticated users, such as subscriber to perform SQL Injection attacks
Feb 13, 2023GigPress: Does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedCVE-2022-4759 · fixed in 2.3.28 · reported by WPScanMedium 5.4
The GigPress WordPress plugin before 2.3.28 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Aug 28, 2019The gigpress plugin before 2.3.11 for WordPress has XSS.CVE-2015-9354 · fixed in 2.3.11 · reported by MITREMedium 4.8
The gigpress plugin before 2.3.11 for WordPress has XSS.
Aug 28, 2019The gigpress plugin before 2.3.11 for WordPress has SQL injection in the admin area, a different vulnerability than CVE-2015-4066.CVE-2015-9353 · fixed in 2.3.11 · reported by MITREHigh 7.2
The gigpress plugin before 2.3.11 for WordPress has SQL injection in the admin area, a different vulnerability than CVE-2015-4066.
May 27, 2015Multiple SQL injection vulnerabilities in admin/handlers.php in the GigPress plugin before 2.3.9 for WordPress allow remote authenticated users to execute arbitCVE-2015-4066 · fixed in 2.3.9 · reported by MITREMedium 6.5
Multiple SQL injection vulnerabilities in admin/handlers.php in the GigPress plugin before 2.3.9 for WordPress allow remote authenticated users to execute arbitrary SQL commands via the (1) show_artist_id or (2) show_venue_id parameter in an add action in the gigpress.php page to wp-admin/admin.php.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.