Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · generateblocks
GenerateBlocks
9 known vulnerabilities on record. Add your version above to see which ones affect you.
Aug 1, 2026GenerateBlocks: Stored Cross-Site ScriptingCVE-2026-13458 · affects up to 2.3.0 · reported by WordfenceMedium 6.4
The GenerateBlocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Dynamic Tag Injection in HTML Attributes in all versions up to, and including, 2.3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A Contributor-level attacker can store the malicious payload by placing a dynamic tag such as {{post_meta key:...}} in a non-URL HTML attribute (e.g., title, aria-label, alt, or data-* attributes) of a GenerateBlocks element block, then setting the corresponding unprotected post meta key via the Custom Fields metabox to a value containing a closing quote and an injected event-handler attribute.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jul 3, 2026GenerateBlocks: Stored Cross-Site ScriptingCVE-2026-9756 · affects up to 2.2.1 · reported by WordfenceMedium 6.4
The GenerateBlocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Headline Block 'linkMetaFieldType' Dynamic Link Attribute in all versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A contributor-level attacker can store a JavaScript payload in their own profile description (allowlisted by get_safe_user_meta_keys()) and prepend 'javascript:' via the linkMetaFieldType attribute, creating a fully attacker-controlled href that executes when any user, including an administrator, clicks the rendered headline link.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
May 27, 2026GenerateBlocks: Insertion of Sensitive Information Into Sent DataCVE-2026-48877 · affects up to 2.1.0 · reported by PatchstackMedium 6.5
Insertion of Sensitive Information Into Sent Data vulnerability in Tom GenerateBlocks allows Retrieve Embedded Sensitive Data. This issue affects GenerateBlocks: from n/a through 2.1.0.
May 5, 2026GenerateBlocks: Insecure Direct Object ReferenceCVE-2026-3454 · affects up to 2.2.0 · reported by WordfenceMedium 6.5
The GenerateBlocks plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.2.0. This is due to missing object-level authorization checks in the /wp-json/generateblocks/v1/dynamic-tag-replacements REST endpoint. The endpoint only verifies that the user has the edit_posts capability but does not verify the user has permission to access the specific post or its associated data referenced by attacker-controlled id parameters in dynamic tag content. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive information from arbitrary posts including author email addresses and non-protected post meta values by crafting dynamic tag payloads such as {{post_meta id:<target>|key:<meta_key>}} and {{post_title id:<target>|link:author_email}}.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Dec 13, 2025GenerateBlocks: Information exposureCVE-2025-12512 · affects up to 2.1.2 · reported by WordfenceMedium 4.3
The GenerateBlocks plugin for WordPress is vulnerable to information exposure due to missing object-level authorization checks in versions up to, and including, 2.1.2. This is due to the plugin registering multiple REST API routes under `generateblocks/v1/meta/` that gate access with `current_user_can('edit_posts')`, which is granted to low-privileged roles such as Contributor. The handlers accept arbitrary entity IDs (user IDs, post IDs, etc.) and meta keys, returning any requested metadata with only a short blacklist of password-like keys for protection. There is no object-level authorization ensuring the caller is requesting only their own data, and there is no allowlist of safe keys. This makes it possible for authenticated attackers, with Contributor-level access and above, to exfiltrate personally identifiable information (PII) and other sensitive profile data of administrator accounts or any other users by directly querying user meta keys via the exposed endpoints via the `get_user_meta_rest` function. In typical WordPress + WooCommerce setups, this includes names, email, phone, and address fields that WooCommerce stores in user meta, enabling targeted phishing, account take
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Oct 25, 2025GenerateBlocks: Unauthorized access of dataCVE-2025-11879 · affects up to 2.1.1 · reported by WordfenceMedium 6.5
The GenerateBlocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'get_option_rest' function in all versions up to, and including, 2.1.1. This makes it possible for authenticated attackers, with contributor level access and above, to read arbitrary WordPress options, including sensitive information such as SMTP credentials, API keys, and other data stored by other plugins.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Mar 1, 2025GenerateBlocks: Sensitive Information ExposureCVE-2024-13546 · affects up to 1.9.1 · reported by WordfenceMedium 4.3
The GenerateBlocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.9.1 via the 'get_image_description' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of private, draft, and scheduled posts and pages.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Mar 13, 2024GenerateBlocks: Sensitive Information ExposureCVE-2024-1452 · affects up to 1.8.2 · reported by WordfenceMedium 4.3
The GenerateBlocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.2 via Query Loop. This makes it possible for authenticated attackers, with contributor access and above, to see contents of posts and pages in draft or private status as well as those with scheduled publication dates.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Nov 29, 2021GenerateBlocks: Does not validate the generateblocks/container block's tagName attributeCVE-2021-24751 · fixed in 1.4.0 · reported by WPScanMedium 5.4
The GenerateBlocks WordPress plugin before 1.4.0 does not validate the generateblocks/container block's tagName attribute, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.