Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · geeky-bot
Geeky Bot
8 known vulnerabilities on record. Add your version above to see which ones affect you.
Aug 13, 2026Unauthenticated Cross Site Scripting (XSS) in GeekyBot <= 1.2.6 versions.CVE-2026-61965 · affects up to 1.2.6 · reported by PatchstackHigh 7.1
Unauthenticated Cross Site Scripting (XSS) in GeekyBot <= 1.2.6 versions.
Jul 31, 2026Geeky Bot: Does not perform an authorization check on one of its AJAX actionsCVE-2026-15048 · fixed in 1.2.8 · reported by WPScanHigh 7.5
The Geeky Bot WordPress plugin before 1.2.8 does not perform an authorization check on one of its AJAX actions, allowing unauthenticated users to retrieve chat-history session metadata including WordPress usernames, user IDs, and timestamps.
Jul 2, 2026Unauthenticated SQL Injection in GeekyBot <= 1.2.5 versions.CVE-2026-57679 · reported by PatchstackCritical 9.3
Unauthenticated SQL Injection in GeekyBot <= 1.2.5 versions.
Jun 15, 2026Unauthenticated Arbitrary File Upload in GeekyBot <= 1.2.2 versions.CVE-2026-40772 · affects up to 1.2.2 · reported by PatchstackCritical 10
Unauthenticated Arbitrary File Upload in GeekyBot <= 1.2.2 versions.
Jun 15, 2026Unauthenticated SQL Injection in GeekyBot <= 1.2.0 versions.CVE-2026-39519 · affects up to 1.2.0 · reported by PatchstackCritical 9.3
Unauthenticated SQL Injection in GeekyBot <= 1.2.0 versions.
May 5, 2026Geeky Bot: Missing AuthorizationCVE-2026-5294 · affects up to 1.2.2 · reported by WordfenceCritical 9.8
The Geeky Bot plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 1.2.2. This is due to a nopriv AJAX route allowing attacker-controlled model/function dispatch and reaching a plugin installer helper that downloads and unzips attacker-supplied ZIP files into wp-content/plugins/. This makes it possible for unauthenticated attackers to perform arbitrary plugin installation and achieve remote code execution.
May 5, 2026GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation: SQL InjectionCVE-2026-3456 · affects up to 1.2.0 · reported by WordfenceHigh 7.5
The GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation plugin for WordPress is vulnerable to SQL Injection via the 'attributekey' parameter in versions up to, and including, 1.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Jan 14, 2026GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation: Stored Cross-Site ScriptingCVE-2025-15266 · affects up to 1.1.8 · reported by WordfenceHigh 7.2
The GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the chat message field in all versions up to, and including, 1.1.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the Chat History page.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.