Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · gd-rating-system
gd-rating-system
7 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 3, 2026GD Rating System: Stored Cross-Site ScriptingCVE-2026-93430 · affects up to 3.7.1 · reported by WordfenceHigh 7.2
The GD Rating System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'title' and 'url' Render Args in gdrts_live_handler AJAX in all versions up to, and including, 3.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Although the AJAX action requires a per-item nonce, that nonce is publicly emitted in the page's <script class="gdrts-rating-data"> JSON block on every page rendering the rating item, making it obtainable by any unauthenticated visitor and therefore not an authentication barrier.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jul 13, 2026GD Rating System: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-57771 · affects up to 3.7 · reported by PatchstackHigh 8.5
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Milan Petrovic GD Rating System gd-rating-system allows Blind SQL Injection.This issue affects GD Rating System: from n/a through <= 3.7.
Jun 15, 2026Unauthenticated SQL Injection in GD Rating System <= 3.6.2 versions.CVE-2026-42639 · affects up to 3.6.2 · reported by PatchstackCritical 9.3
Unauthenticated SQL Injection in GD Rating System <= 3.6.2 versions.
Nov 19, 2024GD Rating System: Stored Cross-Site ScriptingCVE-2024-11198 · affects up to 3.6.1 · reported by WordfenceMedium 6.4
The GD Rating System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘extra_class’ parameter in all versions up to, and including, 3.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jul 12, 2024GD Rating System: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')CVE-2024-38709 · affects up to 3.6 · reported by PatchstackMedium 5.3
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Milan Petrovic GD Rating System allows PHP Local File Inclusion.This issue affects GD Rating System: from n/a through 3.6.
Feb 29, 2024GD Rating System: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-25093 · affects up to 3.5 · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Milan Petrovic GD Rating System allows Stored XSS.This issue affects GD Rating System: from n/a through 3.5.
Aug 27, 2019The gd-rating-system plugin before 2.1 for WordPress has XSS in log.php.CVE-2017-18591 · fixed in 2.1 · reported by MITREMedium 6.1
The gd-rating-system plugin before 2.1 for WordPress has XSS in log.php.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.