Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?FriendsPawFriends - Pet Shop and VeterinaryCross-site scripting (XSS) vulnerability in the BuddyPressTwitter Friends WidgetTop FriendsFriendStore for WooCommerceSend to a Friend Addonthe friends REST API that
Plugin · friends
Friends
3 known vulnerabilities on record. Add your version above to see which ones affect you.
Jul 12, 2025Friends: PHP Object Injection in version 3CVE-2025-7504 · fixed in 3.5.2 · reported by WordfenceHigh 7.5
The Friends plugin for WordPress is vulnerable to PHP Object Injection in version 3.5.1 via deserialization of untrusted input of the query_vars parameter This makes it possible for authenticated attackers, with subscriber-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. This requires access to the sites SALT_NONCE and and SALT_KEY to exploit.
Dec 6, 2024Friends: Unauthorized accessCVE-2024-12028 · affects up to 3.2.1 · reported by WordfenceMedium 5.3
The Friends plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several REST API endpoints in all versions up to, and including, 3.2.1. This makes it possible for unauthenticated attackers to send arbitrary friend requests on behalf of another website, accept the friend request for the targeted website, and then communicate with the site as an accepted friend.
Feb 29, 2024Friends: Server-Side Request ForgeryCVE-2024-1978 · affects up to 2.8.5 · reported by WordfenceMedium 5.5
The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.