Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?FluentBoardsfluent-boards-pro
Plugin · fluent-boards
FluentBoards
10 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 13, 2026FluentBoards: Missing AuthorizationCVE-2026-109696 · affects up to 2.1.0 · reported by PatchstackMedium 5.4
Missing Authorization vulnerability in WP ManageNinja LLC FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through 2.1.0.
Sep 30, 2026Subscriber Privilege Escalation in FluentBoards <= 2.0.12 versions.CVE-2026-96821 · affects up to 2.0.12 · reported by PatchstackMedium 6.3
Subscriber Privilege Escalation in FluentBoards <= 2.0.12 versions.
Sep 23, 2026FluentBoards: Does not properly restrict the member data returned by its publicCVE-2026-89331 · fixed in 2.1.0 · reported by WPScanMedium 5.3
The FluentBoards WordPress plugin before 2.1.0 does not properly restrict the member data returned by its public, token-shared board feature, allowing unauthenticated users to disclose the email addresses of a shared board's members, typically including administrators.
Sep 16, 2026FluentBoards: Does not properly verify that a user holds board-manager privileges before performing several board-management operationsCVE-2026-89328 · fixed in 2.0.15 · reported by WPScanLow 3.8
The FluentBoards WordPress plugin before 2.0.15 does not properly verify that a user holds board-manager privileges before performing several board-management operations, checking only board membership. This allows any member of a board to carry out manager-only actions on it, including adding or removing members and enabling public access to a private board.
Sep 16, 2026FluentBoards: Does not verify that a board member submitting a comment is the user the comment is attributed toCVE-2026-89327 · fixed in 2.0.15 · reported by WPScanLow 3.8
The FluentBoards WordPress plugin before 2.0.15 does not verify that a board member submitting a comment is the user the comment is attributed to, allowing any board member to post comments that appear to be authored by another user, including administrators.
Sep 16, 2026FluentBoards: Does not properly verify authorizationCVE-2026-85349 · fixed in 2.0.15 · reported by WPScanMedium 4.3
The FluentBoards WordPress plugin before 2.0.15 does not properly verify authorization when returning the list of boards a user belongs to, allowing any authenticated user, including a Subscriber with no board access, to disclose the private board memberships of arbitrary users by referencing their user ID.
Aug 2, 2026FluentBoards: Does not verify that the items selected for a board import operation belong to a board the requesting user is authorized to accessCVE-2026-14938 · fixed in 1.95.3 · reported by WPScanMedium 4.3
The FluentBoards WordPress plugin before 1.95.3 does not verify that the items selected for a board import operation belong to a board the requesting user is authorized to access, allowing any authenticated user with member access to a single board to copy and read the stages and tasks (including titles, descriptions and file attachments) of any other board on the site.
Apr 15, 2026FluentBoards: Authorization Bypass Through User-Controlled KeyCVE-2026-40784 · affects up to 1.91.2 · reported by PatchstackHigh 8.1
Authorization Bypass Through User-Controlled Key vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through <= 1.91.2.
Jan 23, 2026FluentBoards: Missing AuthorizationCVE-2026-24561 · affects up to 1.91.1 · reported by PatchstackMedium 5.4
Missing Authorization vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FluentBoards: from n/a through <= 1.91.1.
Apr 17, 2025FluentBoards: Deserialization of Untrusted DataCVE-2025-39551 · affects up to 1.47 · reported by PatchstackCritical 9.8
Deserialization of Untrusted Data vulnerability in Mahmudul Hasan Arif FluentBoards fluent-boards allows Object Injection.This issue affects FluentBoards: from n/a through <= 1.47.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.