Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?Filter GalleryPortfolio Filter Gallery
Plugin · filter-gallery
Filter Gallery
3 known vulnerabilities on record. Add your version above to see which ones affect you.
Sep 18, 2026Filter Gallery: Authorization bypassCVE-2026-89413 · affects up to 1.1.4 · reported by WordfenceHigh 8.1
The Filter Gallery plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.1.4. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete any arbitrary Filter Gallery records — including all associated filters, image mappings, settings, and details options — by supplying attacker-controlled gallery IDs. The nonce bypass requires omitting the nonce POST field entirely rather than submitting an invalid value, as a present-but-invalid nonce is correctly rejected.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Sep 18, 2026Filter Gallery: Authorization bypassCVE-2026-89138 · affects up to 1.1.4 · reported by WordfenceMedium 4.3
The Filter Gallery plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.1.4. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the title and content of arbitrary WordPress posts, write the _wp_attachment_image_alt meta key on arbitrary posts, and create or overwrite arbitrary ufg_gallery_* options.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Sep 18, 2026Filter Gallery: Does not verify the nonce on several of its AJAX handlersCVE-2026-90978 · fixed in 1.1.5 · reported by WPScanHigh 7.1
The Filter Gallery WordPress plugin before 1.1.5 does not verify the nonce on several of its AJAX handlers when the nonce field is omitted, and applies no capability check, allowing low-privileged users to overwrite the content of arbitrary posts and delete the Filter Gallery WordPress plugin before 1.1.5's stored gallery options.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.