Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · eazydocs

EazyDocs

10 known vulnerabilities on record. Add your version above to see which ones affect you.

Is EazyDocs safe? The full page →

  • Apr 10, 2025EazyDocs: Missing AuthorizationCVE-2025-32221 · affects up to 2.7.1 · reported by PatchstackMedium 5.4

    Missing Authorization vulnerability in Spider Themes EazyDocs eazydocs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects EazyDocs: from n/a through <= 2.7.1.

  • Jan 2, 2025EazyDocs: Missing AuthorizationCVE-2023-47648 · affects up to 2.3.5 · reported by PatchstackHigh 7.5

    Missing Authorization vulnerability in Spider Themes EazyDocs eazydocs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects EazyDocs: from n/a through <= 2.3.5.

  • Dec 16, 2024EazyDocs: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2024-54376 · affects up to 2.8.0 · reported by PatchstackHigh 7.5

    Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Spider Themes EazyDocs eazydocs allows PHP Local File Inclusion.This issue affects EazyDocs: from n/a through <= 2.8.0.

  • Nov 1, 2024EazyDocs: Missing AuthorizationCVE-2024-38721 · affects up to 2.5.0 · reported by PatchstackHigh 7.1

    Missing Authorization vulnerability in spider-themes EazyDocs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects EazyDocs: from n/a through 2.5.0.

  • Jul 20, 2024EazyDocs: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-38720 · affects up to 2.5.0 · reported by PatchstackMedium 6.5

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in EazyDocs eazydocs allows Stored XSS.This issue affects EazyDocs: from n/a through 2.5.0.

  • Jul 2, 2024EazyDocs: Does not sanitise and escape some of its settingsCVE-2024-3999 · fixed in 2.5.0 · reported by WPScanMedium 4.8

    The EazyDocs WordPress plugin before 2.5.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

  • Feb 12, 2024EazyDocs: Re-introduced CVE-2023-6029 (https://wpscanCVE-2024-0248 · fixed in 2.4.0 · reported by WPScanMedium 4.3

    The EazyDocs WordPress plugin before 2.4.0 re-introduced CVE-2023-6029 (https://wpscan.com/vulnerability/7a0aaf85-8130-4fd7-8f09-f8edc929597e/) in 2.3.8, allowing any authenticated users, such as subscriber to delete arbitrary posts, as well as add and delete documents/sections. The issue was partially fixed in 2.3.9.

  • Jan 15, 2024EazyDocs: Does not have authorization and CSRF checksCVE-2023-6029 · fixed in 2.3.6 · reported by WPScanHigh 7.5

    The EazyDocs WordPress plugin before 2.3.6 does not have authorization and CSRF checks when handling documents and does not ensure that they are documents from the plugin, allowing unauthenticated users to delete arbitrary posts, as well as add and delete documents/sections.

  • Dec 11, 2023EazyDocs: Does not properly sanitize and escape "data" parameter before using it in an SQL statement via an AJAX actionCVE-2023-6035 · fixed in 2.3.4 · reported by WPScanHigh 8.8

    The EazyDocs WordPress plugin before 2.3.4 does not properly sanitize and escape "data" parameter before using it in an SQL statement via an AJAX action, which could allow any authenticated users, such as subscribers, to perform SQL Injection attacks.

  • Nov 14, 2023Unauth.CVE-2023-47549 · affects up to 2.3.3 · reported by PatchstackMedium 6.8

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability on 302 response page in spider-themes EazyDocs plugin <= 2.3.3 versions.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.