Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?Easy Property ListingsImport into Easy Property Listings
Plugin · easy-property-listings
Easy Property Listings
11 known vulnerabilities on record. Add your version above to see which ones affect you.
Oct 20, 2026Easy Property Listings: Does not perform authorisation checks on several of its contact-management read AJAX actionsCVE-2026-96903 · fixed in 3.5.27 · reported by WPScanMedium 4.3
The Easy Property Listings WordPress plugin before 3.5.27 does not perform authorisation checks on several of its contact-management read AJAX actions, allowing any authenticated user with a role as low as subscriber to read other users' CRM contact and lead records, including their private activity notes.
Oct 20, 2026Easy Property Listings: Does not restrictCVE-2026-96902 · fixed in 3.5.28 · reported by WPScanMedium 5.3
The Easy Property Listings WordPress plugin before 3.5.28 does not restrict which listing fields it adds to the public REST API output, allowing unauthenticated users to read details a site has chosen to hide on published listings, such as the asking price, sold price, street address and exact map coordinates.
Aug 1, 2026Easy Property Listings: Stored Cross-Site ScriptingCVE-2026-16684 · affects up to 3.5.24 · reported by WordfenceMedium 6.4
The Easy Property Listings plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'facebook' User Contact Method in all versions up to, and including, 3.5.24 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jan 22, 2026Easy Property Listings: Missing AuthorizationCVE-2025-68072 · affects up to 3.5.20 · reported by PatchstackMedium 6.5
Missing Authorization vulnerability in Merv Barrett Easy Property Listings easy-property-listings allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Property Listings: from n/a through <= 3.5.20.
Dec 16, 2025Easy Property Listings: Missing AuthorizationCVE-2025-64242 · affects up to 3.5.22 · reported by PatchstackMedium 4.3
Missing Authorization vulnerability in Merv Barrett Easy Property Listings easy-property-listings allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Property Listings: from n/a through <= 3.5.22.
May 15, 2025Easy Property Listings: Does not sanitise and escape some of its settingsCVE-2024-2869 · fixed in 3.5.4 · reported by WPScanMedium 4.8
The Easy Property Listings WordPress plugin before 3.5.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Sep 12, 2024Easy Property Listings: Does not have CSRF checkCVE-2024-3163 · fixed in 3.5.4 · reported by WPScanMedium 4.3
The Easy Property Listings WordPress plugin before 3.5.4 does not have CSRF check when deleting contacts in bulk, which could allow attackers to make a logged in admin delete them via a CSRF attack
Jun 9, 2024Easy Property Listings: Missing AuthorizationCVE-2024-32799 · affects up to 3.5.3 · reported by PatchstackMedium 5.3
Missing Authorization vulnerability in Merv Barrett Easy Property Listings.This issue affects Easy Property Listings: from n/a through 3.5.3.
Apr 9, 2024Easy Property Listings: Time-based SQL InjectionCVE-2024-1893 · affects up to 3.5.2 · reported by WordfenceHigh 8.8
The Easy Property Listings plugin for WordPress is vulnerable to time-based SQL Injection via the ‘property_status’ shortcode attribute in all versions up to, and including, 3.5.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Feb 18, 2020Easy Property Listings versions prior to 3.4: Cross-site request forgery (CSRF)CVE-2020-5530 · fixed in 3.4 · reported by vultures@jpcert.or.jpHigh 8.8
Cross-site request forgery (CSRF) vulnerability in Easy Property Listings versions prior to 3.4 allows remote attackers to hijack the authentication of administrators via unspecified vectors.
Aug 30, 2019The easy-property-listings plugin before 3.4 for WordPress has XSS.CVE-2019-15817 · fixed in 3.4 · reported by MITREMedium 6.1
The easy-property-listings plugin before 3.4 for WordPress has XSS.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.