Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · cornerstone
cornerstone
7 known vulnerabilities on record. Add your version above to see which ones affect you.
Jun 24, 2026Cornerstone: Does not enforce capability checks on one of its CSS-preview request handlersCVE-2026-9710 · fixed in 7.8.8 · reported by WPScanHigh 7.7
The Cornerstone WordPress plugin before 7.8.8 does not enforce capability checks on one of its CSS-preview request handlers, and exposes the nonce needed to call it to every logged-in user on any wp-admin page, allowing any authenticated user to evaluate dynamic content tokens against arbitrary users and disclose their sensitive metadata including raw password hashes. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.8 (v0.8.x) on the .org repository.
Jun 24, 2026Cornerstone: Does not enforce capability checks on one of its REST API routesCVE-2026-9709 · fixed in 7.8.9 · reported by WPScanHigh 7.7
The Cornerstone WordPress plugin before 7.8.9 does not enforce capability checks on one of its REST API routes, allowing any authenticated user to disclose the metadata of any other user, including roles, session token previews and stored billing/shipping fields. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.9 (v0.8.x) on the .org repository.
Jun 17, 2026Subscriber SQL Injection in Cornerstone < 7.8.8 versions.CVE-2026-54185 · reported by PatchstackHigh 8.5
Subscriber SQL Injection in Cornerstone < 7.8.8 versions.
Jun 17, 2026Subscriber Arbitrary Code Execution in Cornerstone < 7.8.8 versions.CVE-2026-49113 · reported by PatchstackHigh 8.5
Subscriber Arbitrary Code Execution in Cornerstone < 7.8.8 versions.
Dec 9, 2025Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-63072 · affects up to 7.7.3 · reported by PatchstackMedium 6.5
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in THEMECO Cornerstone cornerstone allows Stored XSS.This issue affects Cornerstone: from n/a through <= 7.7.3.
Apr 18, 2024Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32570 · affects up to 0.8.0 · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.
Mar 28, 2024Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-28002 · affects up to 0.8.0 · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.