Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · cforms2

cforms2

13 known vulnerabilities on record. Add your version above to see which ones affect you.

Is cforms2 safe? The full page →

  • Jun 15, 2026Unauthenticated Cross Site Scripting (XSS) in CformsII <= 15.1.3 versions.CVE-2026-39435 · affects up to 15.1.3 · reported by PatchstackHigh 7.1

    Unauthenticated Cross Site Scripting (XSS) in CformsII <= 15.1.3 versions.

  • May 25, 2026CformsII: Cross-Site Request Forgery (CSRF)CVE-2026-39436 · affects up to 15.1.3 · reported by PatchstackHigh 7.1

    Cross-Site Request Forgery (CSRF) vulnerability in bgermann CformsII allows Cross Site Request Forgery. This issue affects CformsII: from n/a through 15.1.3.

  • Mar 27, 2024CformsII: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-22149 · affects up to 15.0.5 · reported by PatchstackHigh 7.1

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Oliver Seidel, Bastian Germann CformsII allows Stored XSS.This issue affects CformsII: from n/a through 15.0.5.

  • Jan 8, 2024cformsII: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-52203 · affects up to 15.0.5 · reported by PatchstackMedium 5.9

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Oliver Seidel, Bastian Germann cformsII allows Stored XSS.This issue affects cformsII: from n/a through 15.0.5.

  • Jun 15, 2023Cross-Site Request Forgery (CSRF) vulnerability in Oliver Seidel, Bastian Germann cformsII plugin <= 15.0.4 versions.CVE-2023-25449 · fixed in 15.0.5 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in Oliver Seidel, Bastian Germann cformsII plugin <= 15.0.4 versions.

  • Aug 22, 2019The cforms2 plugin before 10.5 for WordPress has XSS.CVE-2014-10393 · fixed in 10.5 · reported by MITREMedium 6.1

    The cforms2 plugin before 10.5 for WordPress has XSS.

  • Aug 22, 2019The cforms2 plugin before 10.2 for WordPress has XSS.CVE-2014-10392 · fixed in 10.2 · reported by MITREMedium 6.1

    The cforms2 plugin before 10.2 for WordPress has XSS.

  • Aug 22, 2019The cforms2 plugin before 14.13 for WordPress has SQL injection in the tracking DB GUI via Delete Entries or Download Entries.CVE-2017-18570 · fixed in 14.13 · reported by MITRECritical 9.8

    The cforms2 plugin before 14.13 for WordPress has SQL injection in the tracking DB GUI via Delete Entries or Download Entries.

  • Aug 22, 2019The cforms2 plugin before 14.6.10 for WordPress has SQL injection.CVE-2015-9333 · fixed in 14.6.10 · reported by MITRECritical 9.8

    The cforms2 plugin before 14.6.10 for WordPress has SQL injection.

  • Aug 21, 2019The cforms2 plugin before 14.13.3 for WordPress has multiple XSS issues.CVE-2017-18559 · fixed in 14.13.3 · reported by MITREMedium 6.1

    The cforms2 plugin before 14.13.3 for WordPress has multiple XSS issues.

  • Aug 21, 2019The cforms2 plugin before 13.2 for WordPress has XSS in lib_ajax.php.CVE-2014-10377 · fixed in 13.2 · reported by MITREMedium 6.1

    The cforms2 plugin before 13.2 for WordPress has XSS in lib_ajax.php.

  • Aug 20, 2019The cforms2 plugin before 15.0.2 for WordPress has CSRF related to the IP address field.CVE-2019-15238 · fixed in 15.0.2 · reported by MITREHigh 8.8

    The cforms2 plugin before 15.0.2 for WordPress has CSRF related to the IP address field.

  • Jan 7, 2015Unrestricted file upload vulnerability in lib_nonajax.php in the CformsII plugin 14.7 and earlier for WordPress allows remote attackers to execute arbitrary codCVE-2014-9473 · affects up to 14.7 · reported by MITREHigh 7.5

    Unrestricted file upload vulnerability in lib_nonajax.php in the CformsII plugin 14.7 and earlier for WordPress allows remote attackers to execute arbitrary code by uploading a file with an executable extension via the cf_uploadfile2[] parameter, then accessing the file via a direct request to the file in the default upload directory.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.