Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · breakdance

breakdance

8 known vulnerabilities on record. Add your version above to see which ones affect you.

Is breakdance safe? The full page →

  • Aug 6, 2026Breakdance: Missing AuthorizationCVE-2026-65551 · fixed in 2.7 · reported by PatchstackHigh 7.5

    Missing Authorization vulnerability in Soflyy Breakdance allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Breakdance: from n/a before 2.7.

  • Jul 23, 2026Unauthenticated Cross Site Scripting (XSS) in Breakdance <= 2.7.1 versions.CVE-2026-57735 · affects up to 2.7.1 · reported by PatchstackHigh 7.1

    Unauthenticated Cross Site Scripting (XSS) in Breakdance <= 2.7.1 versions.

  • Jul 16, 2026Breakdance: Stored Cross-Site ScriptingCVE-2026-7543 · affects up to 2.7.1 · reported by WordfenceHigh 7.2

    The Breakdance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields' parameter in versions up to, and including, 2.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Aug 1, 2024Breakdance: Unauthorized access of dataCVE-2024-5331 · affects up to 1.7.2 · reported by WordfenceMedium 4.3

    The Breakdance plugin for WordPress is vulnerable to unauthorized access of data in all versions up to, and including, 1.7.2. This makes it possible for authenticated attackers, with Contributor-level access and above, to export form submissions.

  • Aug 1, 2024Breakdance: Stored Cross-Site ScriptingCVE-2024-5330 · affects up to 1.7.2 · reported by WordfenceMedium 6.4

    The Breakdance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the breakdance_css_file_paths_cache parameter in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • May 14, 2024Breakdance: Remote Code ExecutionCVE-2024-4605 · affects up to 1.7.1 · reported by WordfenceHigh 8.8

    The Breakdance plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.7.1 via post meta data. This is due to the plugin storing custom data in metadata without an underscore prefix. This makes it possible for lower privileged users, such as contributors, to edit this data via UI. As a result they can escalate their privileges or execute arbitrary code.

  • May 6, 2024Breakdance: Stored Cross-Site ScriptingCVE-2023-6854 · affects up to 1.7.0 · reported by WordfenceMedium 6.4

    The Breakdance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's custom postmeta output in all versions up to, and including, 1.7.0 due to insufficient input sanitization and output escaping on user supplied post meta fields. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Apr 3, 2024Breakdance: : Improper Control of Generation of Code ('Code Injection')CVE-2024-31390 · affects up to 1.7.2 · reported by PatchstackCritical 9.9

    : Improper Control of Generation of Code ('Code Injection') vulnerability in Soflyy Breakdance allows : Code Injection.This issue affects Breakdance: from n/a through 1.7.2.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.