Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,080 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?JetBackupWPvividbackup-backupEverest BackupXClonerWP Database BackupAll-in-One WP Migration and BackupBackup and Staging by
Plugin · wp-database-backup
WP Database Backup
10 known vulnerabilities on record. Add your version above to see which ones affect you.
Jul 2, 2026WP Database Backup – Unlimited Database & Files Backup by Backup for WP: OS Command InjectionCVE-2026-9834 · affects up to 7.11 · reported by WordfenceHigh 7.2
The WP Database Backup – Unlimited Database & Files Backup by Backup for WP plugin for WordPress is vulnerable to OS Command Injection in all versions up to and including 7.11 via the `wp_db_exclude_table` parameter. This is due to the direct concatenation of user-supplied `$_POST['wp_db_exclude_table']` values into the `mysqldump` shell command string in the `mysqldump()` function of `includes/admin/class-wpdb-admin.php` without wrapping them in `escapeshellarg()`—every other argument in the same command (DB_USER, DB_PASSWORD, host, filename, DB_NAME) is properly escaped, making the exclude-table values the sole exception—and because the only applied filtering, `sanitize_text_field()` via `recursive_sanitize_text_field()`, strips HTML tags but leaves shell metacharacters such as `;`, `|`, `` ` ``, and `$()` intact. This makes it possible for authenticated attackers, with administrator-level access and above, to execute arbitrary operating system commands on the server, potentially enabling full remote code execution. The injection is stored: malicious values submitted through the plugin settings form are persisted to the WordPress options table via `update_option('wp_db_exclude_ta
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Jul 24, 2025WP Database Backup: OS Command InjectionCVE-2019-25224 · fixed in 5.2 · reported by WordfenceCritical 9.8
The WP Database Backup plugin for WordPress is vulnerable to OS Command Injection in versions before 5.2 via the mysqldump function. This vulnerability allows unauthenticated attackers to execute arbitrary commands on the host operating system.
Jan 9, 2025WP Database Backup – Unlimited Database & Files Backup by Backup for WP: Sensitive Information ExposureCVE-2024-12330 · affects up to 7.3 · reported by WordfenceHigh 7.5
The WP Database Backup – Unlimited Database & Files Backup by Backup for WP plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.3 via publicly accessible back-up files. This makes it possible for unauthenticated attackers to extract sensitive data including all information stored in the database.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Sep 5, 2022WP Database Backup: Does not escape some of its settingsCVE-2022-2271 · fixed in 5.9 · reported by WPScanMedium 4.8
The WP Database Backup WordPress plugin before 5.9 does not escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Jan 20, 2020The WP Database Backup plugin through 5.5 for WordPress stores downloads by default locally in the directory wp-content/uploads/db-backup/.CVE-2020-7241 · affects up to 5.5 · reported by MITREHigh 7.5
The WP Database Backup plugin through 5.5 for WordPress stores downloads by default locally in the directory wp-content/uploads/db-backup/. This might allow attackers to read ZIP archives by guessing random ID numbers, guessing date strings with a 2020_{0..1}{0..2}_{0..3}{0..9} format, guessing UNIX timestamps, and making HTTPS requests with the complete guessed URL.
Aug 12, 2019The wp-database-backup plugin before 5.1.2 for WordPress has XSS.CVE-2019-14949 · fixed in 5.1.2 · reported by MITREMedium 6.1
The wp-database-backup plugin before 5.1.2 for WordPress has XSS.
Aug 12, 2019The wp-database-backup plugin before 4.3.1 for WordPress has CSRF.CVE-2016-10876 · fixed in 4.3.1 · reported by MITREHigh 8.8
The wp-database-backup plugin before 4.3.1 for WordPress has CSRF.
Aug 12, 2019The wp-database-backup plugin before 4.3.1 for WordPress has XSS.CVE-2016-10875 · fixed in 4.3.1 · reported by MITREMedium 6.1
The wp-database-backup plugin before 4.3.1 for WordPress has XSS.
Aug 12, 2019The wp-database-backup plugin before 4.3.3 for WordPress has CSRF.CVE-2016-10874 · fixed in 4.3.3 · reported by MITREHigh 8.8
The wp-database-backup plugin before 4.3.3 for WordPress has CSRF.
Aug 12, 2019The wp-database-backup plugin before 4.3.3 for WordPress has XSS.CVE-2016-10873 · fixed in 4.3.3 · reported by MITREMedium 6.1
The wp-database-backup plugin before 4.3.3 for WordPress has XSS.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.