Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?AvadaAvada (Fusion) BuilderAvada CoreBravada

Theme · avada

Avada

16 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Avada safe? The full page →

  • Aug 26, 2026Avada: Arbitrary File WriteCVE-2026-18431 · affects up to 7.16 · reported by WordfenceCritical 9.8

    The Avada theme for WordPress is vulnerable to Arbitrary File Write in all versions up to, and including, 7.16 when the Fusion Builder plugin is installed and active in versions up to, and including, 3.16. This is due to a chain of authorization and input validation weaknesses across the two components that makes it possible for unauthenticated attackers to write attacker-controlled files to the server. This can be used to create and execute arbitrary PHP files, resulting in remote code execution and complete site compromise. Successful exploitation requires both Avada and Fusion Builder to be installed and active, as well as certain administrator-authored content to be present.

  • Apr 22, 2026Avada: Cross-Site Request Forgery (CSRF)CVE-2025-58922 · fixed in 7.13.2 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in ThemeFusion Avada allows Cross Site Request Forgery.This issue affects Avada: from n/a before 7.13.2.

  • Dec 16, 2025Avada: Missing AuthorizationCVE-2025-64634 · affects up to 7.13.2 · reported by PatchstackMedium 5.3

    Missing Authorization vulnerability in ThemeFusion Avada avada allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Avada: from n/a through <= 7.13.2.

  • Jul 4, 2025Avada: Missing AuthorizationCVE-2025-24748 · affects up to 7.11.10 · reported by PatchstackMedium 5.3

    Missing Authorization vulnerability in ThemeFusion Avada avada.This issue affects Avada: from n/a through <= 7.11.10.

  • Dec 16, 2024Avada: Cross-Site Request Forgery (CSRF)CVE-2024-54357 · affects up to 7.11.10 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in ThemeFusion Avada avada.This issue affects Avada: from n/a through <= 7.11.10.

  • Jun 19, 2024Avada: Missing AuthorizationCVE-2023-39312 · affects up to 7.11.1 · reported by PatchstackCritical 9.1

    Missing Authorization vulnerability in ThemeFusion Avada.This issue affects Avada: from n/a through 7.11.1.

  • Jun 19, 2024Avada: Missing AuthorizationCVE-2023-39922 · affects up to 7.11.1 · reported by PatchstackMedium 4.3

    Missing Authorization vulnerability in ThemeFusion Avada.This issue affects Avada: from n/a through 7.11.1.

  • Apr 9, 2024Avada: SQL InjectionCVE-2024-2344 · affects up to 7.11.6 · reported by WordfenceHigh 7.2

    The Avada theme for WordPress is vulnerable to SQL Injection via the 'entry' parameter in all versions up to, and including, 7.11.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticted attackers, with editor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

  • Apr 9, 2024Avada: Sensitive Information ExposureCVE-2024-2340 · affects up to 7.11.6 · reported by WordfenceMedium 5.3

    The Avada theme for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.11.6 via the '/wp-content/uploads/fusion-forms/' directory. This makes it possible for unauthenticated attackers to extract sensitive data uploaded via an Avada created form with a file upload mechanism.

  • Apr 9, 2024Avada: Stored Cross-Site ScriptingCVE-2024-2311 · affects up to 7.11.6 · reported by WordfenceMedium 6.4

    The Avada theme for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 7.11.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Mar 28, 2024Avada: Server-Side Request Forgery (SSRF)CVE-2023-39313 · affects up to 7.11.1 · reported by PatchstackHigh 7.7

    Server-Side Request Forgery (SSRF) vulnerability in ThemeFusion Avada.This issue affects Avada: from n/a through 7.11.1.

  • Mar 26, 2024Avada: Unrestricted Upload of File with Dangerous TypeCVE-2023-39307 · affects up to 7.11.1 · reported by PatchstackHigh 8.5

    Unrestricted Upload of File with Dangerous Type vulnerability in ThemeFusion Avada.This issue affects Avada: from n/a through 7.11.1.

  • Jun 6, 2023Avada: Stored Cross-Site ScriptingCVE-2020-36711 · affects up to 6.2.3 · reported by WordfenceMedium 6.4

    The Avada theme for WordPress is vulnerable to Stored Cross-Site Scripting via the update_layout function in versions up to, and including, 6.2.3 due to insufficient input sanitization and output escaping. This makes it possible for contributor-level attackers, and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Oct 27, 2022Cross-Site Request Forgery (CSRF) vulnerability in ThemeFusion Avada premium theme versions <= 7.8.1 on WordPress leading to arbitrary plugin installation/activCVE-2022-41996 · affects up to 7.8.1 · reported by PatchstackHigh 8.8

    Cross-Site Request Forgery (CSRF) vulnerability in ThemeFusion Avada premium theme versions <= 7.8.1 on WordPress leading to arbitrary plugin installation/activation.

  • Sep 10, 2019The avada theme before 5.1.5 for WordPress has CSRF.CVE-2017-18607 · fixed in 5.1.5 · reported by MITREHigh 8.8

    The avada theme before 5.1.5 for WordPress has CSRF.

  • Sep 10, 2019The avada theme before 5.1.5 for WordPress has stored XSS.CVE-2017-18606 · fixed in 5.1.5 · reported by MITREMedium 6.1

    The avada theme before 5.1.5 for WordPress has stored XSS.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.