Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?Affiliatesaffiliates-managerCoupon AffiliatesThirstyAffiliatesSUMO Affiliates ProAffiliate Program Suite — SliceWP AffiliatesStoreEngine — Complete eCommerce Solution with Memberships, Licensing, Affiliates & MoreWoocommerce Envato Affiliates

Plugin · thirstyaffiliates

ThirstyAffiliates

4 known vulnerabilities on record. Add your version above to see which ones affect you.

Is ThirstyAffiliates safe? The full page →

  • Oct 17, 2026ThirstyAffiliates: Does not check the status or type of the object requested by its link redirect tracking handlerCVE-2026-97314 · fixed in 3.12.1 · reported by WPScanMedium 6.5

    The ThirstyAffiliates WordPress plugin before 3.12.1 does not check the status or type of the object requested by its link redirect tracking handler, allowing unauthenticated attackers to disclose the destination URLs of unpublished affiliate links and to record fabricated click statistics.

  • Feb 3, 2026ThirstyAffiliates: Cross-Site Request Forgery (CSRF)CVE-2026-25024 · affects up to 3.11.9 · reported by PatchstackMedium 5.4

    Cross-Site Request Forgery (CSRF) vulnerability in Blair Williams ThirstyAffiliates thirstyaffiliates allows Cross Site Request Forgery.This issue affects ThirstyAffiliates: from n/a through <= 3.11.9.

  • Dec 9, 2025ThirstyAffiliates: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-67537 · affects up to 3.11.8 · reported by PatchstackMedium 6.5

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Blair Williams ThirstyAffiliates thirstyaffiliates allows Stored XSS.This issue affects ThirstyAffiliates: from n/a through <= 3.11.8.

  • Apr 25, 2022ThirstyAffiliates: Lacks authorization checks in the ta_insert_external_image actionCVE-2022-0634 · fixed in 3.10.5 · reported by WPScanMedium 4.3

    The ThirstyAffiliates WordPress plugin before 3.10.5 lacks authorization checks in the ta_insert_external_image action, allowing a low-privilege user (with a role as low as Subscriber) to add an image from an external URL to an affiliate link. Further the plugin lacks csrf checks, allowing an attacker to trick a logged in user to perform the action by crafting a special request.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.