Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 391,288 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?HustlePopup Box – Best WordPress PopupPopup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead GenerationWP Popups – WordPress Popup builderPopup Box – Easily Create WordPress Popups
Plugin · wp-popups-lite
WP Popups – WordPress Popup builder
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Is WP Popups – WordPress Popup builder safe? The full page →
Jan 23, 2026WP Popups: Missing AuthorizationCVE-2026-24616 · affects up to 2.2.0.5 · reported by PatchstackMedium 6.5
Missing Authorization vulnerability in Damian WP Popups wp-popups-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Popups: from n/a through <= 2.2.0.5.
Jul 12, 2024WP Popups – WordPress Popup builder: Full Path DisclosureCVE-2024-6555 · affects up to 2.2.0.1 · reported by WordfenceMedium 5.3
The WP Popups – WordPress Popup builder plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.2.0.1. This is due the plugin utilizing mobiledetect without preventing direct access to the files. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.
Mar 19, 2024WP Popups: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29105 · affects up to 2.1.5.5 · reported by PatchstackMedium 5.9
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Timersys WP Popups allows Stored XSS.This issue affects WP Popups: from n/a through 2.1.5.5.
May 8, 2023WP Popups: Does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embedCVE-2023-1905 · fixed in 2.1.5.1 · reported by WPScanMedium 5.4
The WP Popups WordPress plugin before 2.1.5.1 does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This is due to an insufficient fix of CVE-2023-24003
Apr 6, 2023Auth.CVE-2023-24003 · fixed in 2.1.4.9 · reported by PatchstackMedium 6.5
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Timersys WP Popups – WordPress Popup plugin <= 2.1.4.8 versions.
Jan 23, 2023WP Popups: Does not validate and escape some of its shortcode attributes before outputting them back in the pageCVE-2022-4716 · fixed in 2.1.4.8 · reported by WPScanMedium 5.4
The WP Popups WordPress plugin before 2.1.4.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.