Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Not this one?Donation Plugin and Fundraising PlatformWP Affiliate Platformbuddyboss-platformWawpFundEngine – Donation and Crowdfunding PlatformCLUEVO LMS, E-Learning PlatformOttoKit: All-in-One Automation PlatformAdvanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms

Plugin · buddyboss-platform

buddyboss-platform

8 known vulnerabilities on record. Add your version above to see which ones affect you.

Is buddyboss-platform safe? The full page →

  • Oct 6, 2026Subscriber SQL Injection in Buddyboss Platform <= 3.1.0 versions.CVE-2026-39771 · affects up to 3.1.0 · reported by PatchstackHigh 8.5

    Subscriber SQL Injection in Buddyboss Platform <= 3.1.0 versions.

  • Jul 23, 2026Unauthenticated SQL Injection in Buddyboss Platform <= 3.0.5 versions.CVE-2026-59514 · affects up to 3.0.5 · reported by PatchstackCritical 9.3

    Unauthenticated SQL Injection in Buddyboss Platform <= 3.0.5 versions.

  • Jun 26, 2026Subscriber PHP Object Injection in Buddyboss Platform <= 3.0.4 versions.CVE-2026-56032 · reported by PatchstackCritical 9.8

    Subscriber PHP Object Injection in Buddyboss Platform <= 3.0.4 versions.

  • May 15, 2025The buddyboss-platform WordPress plugin before 2.7.60 lacks proper access controls and allows a logged-in user to view comments on private postsCVE-2024-12767 · fixed in 2.7.60 · reported by WPScanLow 3.5

    The buddyboss-platform WordPress plugin before 2.7.60 lacks proper access controls and allows a logged-in user to view comments on private posts

  • May 2, 2025Buddyboss Platform: Stored Cross-Site ScriptingCVE-2024-13860 · affects up to 2.8.50 · reported by WordfenceMedium 6.4

    The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘bbp_topic_title’ parameter in all versions up to, and including, 2.8.50 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.41.

  • May 2, 2025Buddyboss Platform: Stored Cross-Site ScriptingCVE-2024-13859 · affects up to 2.8.50 · reported by WordfenceMedium 6.4

    The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘bp_nouveau_ajax_media_save’ function in all versions up to, and including, 2.8.50 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.41.

  • Feb 27, 2025Buddyboss Platform: Stored Cross-Site ScriptingCVE-2024-13402 · affects up to 2.7.70 · reported by WordfenceMedium 6.4

    The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘link_title’ parameter in all versions up to, and including, 2.7.70 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Jun 4, 2024The buddyboss-platform WordPress plugin before 2.6.0 contains an IDOR vulnerability that allows a user to like a private post by manipulating the ID included inCVE-2024-4750 · fixed in 2.6.0 · reported by WPScanMedium 5.3

    The buddyboss-platform WordPress plugin before 2.6.0 contains an IDOR vulnerability that allows a user to like a private post by manipulating the ID included in the request

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.