Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Not this one?duplicate-postDuplicate Post Page Menu & Custom Post TypePublishPress Revisions: Duplicate Posts, Submit, Approve and Schedule Content ChangesDuplicate PostDuplicate Page and PostDuplica – Duplicate Posts, Pages, Custom Posts or UsersDelete Duplicate PostsRemove Duplicate Posts
Plugin · duplicate-post
duplicate-post
6 known vulnerabilities on record. Add your version above to see which ones affect you.
Jun 10, 2026Yoast Duplicate Post through 4.6 inserts an unescaped post title and permalink into the Classic Editor scheduled republish notice.CVE-2026-53740 · affects up to 4.6 · reported by VulnCheckMedium 5.1
Yoast Duplicate Post through 4.6 inserts an unescaped post title and permalink into the Classic Editor scheduled republish notice. Attackers can schedule a republish copy with a crafted title to execute script when an administrator views the resulting notice.
Jun 10, 2026the duplicate_post_dismiss_notice handler, which verifies no nonce or capability: Yoast Duplicate Post through 4.6 contains a cross-site request forgeryCVE-2026-53739 · affects up to 4.6 · reported by VulnCheckMedium 5.1
Yoast Duplicate Post through 4.6 contains a cross-site request forgery vulnerability in the duplicate_post_dismiss_notice handler, which verifies no nonce or capability. Attackers can trick any authenticated user into sending a request that sets the duplicate_post_show_notice site option, suppressing admin notices network-wide.
Mar 18, 2026Yoast Duplicate Post: Unauthorized modification of dataCVE-2026-1217 · affects up to 4.5 · reported by WordfenceMedium 5.4
The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.
NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Feb 11, 2026plugin settings parameters: Yoast Duplicate-Post WordPress Plugin 3.2.3 contains a persistent cross-site scriptingCVE-2019-25314 · reported by VulnCheckMedium 4.8
Yoast Duplicate-Post WordPress Plugin 3.2.3 contains a persistent cross-site scripting vulnerability in plugin settings parameters. Attackers can inject malicious scripts into title prefix, suffix, menu order, and blacklist fields to execute arbitrary JavaScript in admin interfaces.
Aug 21, 2019The duplicate-post plugin before 2.6 for WordPress has SQL injection.CVE-2014-10379 · fixed in 2.6 · reported by MITRECritical 9.8
The duplicate-post plugin before 2.6 for WordPress has SQL injection.
Aug 21, 2019The duplicate-post plugin before 2.6 for WordPress has XSS.CVE-2014-10378 · fixed in 2.6 · reported by MITREMedium 6.1
The duplicate-post plugin before 2.6 for WordPress has XSS.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.