Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
CriticalCVSS v4.0 9.2Fixed in Brotli 1.2.1 and Node.js updates

A flaw in Brotli, the compression behind fast websites, is on CISA’s exploited list

Brotli is the compression format most of the web uses to make pages load faster. CVE-2026-111497 is a buffer overflow in its decoder: a crafted compressed stream can corrupt memory and possibly run an attacker’s code. Node.js shipped fixes on October 21, and CISA added the flaw to its exploited list on October 27.

Nikita HuttenlocherFounder and lead engineer, Huttenlocher Technologies
Published October 28, 20263 min read
Update: If your website or app was built by a developer, ask them which Node.js version it runs and whether it’s on the October 21 security release.

What it is

Brotli shrinks pages and files so they travel faster, and the software on the other end unpacks them. The bug is in that unpacking step. According to the NVD record, a crafted Brotli stream can “corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code.”

The risk is in software that unpacks Brotli it didn’t make: a server or app that fetches pages or files from other sites, or accepts compressed uploads. A plain website that only serves its own pages is far less exposed, but it still runs the vulnerable code until it’s updated.

Who it touches

  • Websites and apps built on Node.js. Node.js ships Brotli inside it. The Node.js October 21 security release fixes it in 22.23.4, 24.22.1 and 26.12.1. Anything older in those lines is affected.
  • Servers and tools that use the Brotli library directly, in any language. Versions 1.0.3 through 1.2.0 are affected; update to 1.0.10, 1.1.1 or 1.2.1.
  • Your own computer’s browser gets its fixes through normal browser updates. Keep automatic updates on.

Three questions for whoever runs your website

  1. Does our site or app run on Node.js?Many modern sites and booking or payment systems do. WordPress sites run on PHP instead, which has its own urgent update this month (see our PHP2Shell advisory).
  2. Which version, and is it on the October 21 release?22.23.4, 24.22.1 or 26.12.1, or later. If the site runs on a managed hosting platform, ask whether the platform has rolled the patched runtime out yet.
  3. Does anything we run fetch files from other websites?Link previews, price checkers, feed readers and website scanners all do. Those are the parts that most need the update, and they can be told to refuse Brotli until then.

Our own website scanners stopped accepting Brotli the week the fix was announced, so a malicious site can’t feed them a crafted stream while the hosting runtime catches up. If you’re not sure what your site runs, ask us.

Written by Nikita Huttenlocher, founder and lead engineer at Huttenlocher Technologies, a cybersecurity and software firm in Myrtle Beach, South Carolina. This is general guidance, not a review of your systems.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.